GeoTrust Web Browser Compatibility

Web Browsers (SSL enabled)

  • Microsoft IE 5.01+
  • Netscape Communicator 4.51+
  • Mozilla Firefox 1.0+
  • Mozilla Suite 1.0+
  • AOL 5+
  • Opera 7+
  • Apple Safari 1.0+
  • Red Hat Linux Konqueror
  • Sony Playstation
  • Microsoft WebTV

    Micro Browsers (SSL Enabled)

    • Netfront 3.0+
    • Opera 7.0+
    • Palm / Handspring Blazer 2.0+
    • Microsoft Windows CE 2003
    • Microsoft Internet Explorer Pocket PC 2003
    • Microsoft Internet Explorer Smartphone 2003
    • Blackberry 4.0+
    • AT&T
    • Sony Playstation Portable
    • Sony Netjuke audio
    • Brew
    • Openwave
    • NTT Do Co Mo
    • Vodaphone

      Email Clients (S/Mime)

      • Microsoft Outlook 99+
      • Netscape Communicator 4.51+
      • Mozilla Thunderbird 1.0+
      • Qualcomm Eudora 6.2+
      • Lotus Notes
      • Mulberry Email 3.1.6+

        Application Clients and Servers

        • Sun J2SE 1.4.2_02
        • Sun J2EE 1.4.2_02
        • IBM Web Sphere Micro Environment (WME)
        • IBM Web Sphere Custom Environment (WCE)